summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-10-11 09:59:36 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-14 17:07:36 +0200
commit3aa440caef15fa9d407508551bb48654a64d6564 (patch)
treeca5580b9d96a2ff9c3a30f36615307e14d5ccfd1
parent7ae282fbea32bcfb50a1df7b78107c67a4ae3648 (diff)
downloadguix-patches-3aa440caef15fa9d407508551bb48654a64d6564.tar
guix-patches-3aa440caef15fa9d407508551bb48654a64d6564.tar.gz
gnu: Add python-py-ubjson.
* gnu/packages/web.scm (python-py-ubjson): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/web.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0d2a247e12..41e52756e3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5365,3 +5365,22 @@ file links.")
file upload, download, on-screen display, namespace operations (move/copy),
collection creation and deletion, and locking operations.")
(license l:gpl2)))
+
+(define-public python-py-ubjson
+ (package
+ (name "python-py-ubjson")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "py-ubjson" version))
+ (sha256
+ (base32
+ "03l9m9w5ip4hw0y69wlys5gzsfb7zcq3a77blj88grgiqhn5vm5n"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/Iotic-Labs/py-ubjson")
+ (synopsis "Universal Binary JSON encoder/decoder")
+ (description
+ "Py-ubjson is a Python module providing an Universal Binary JSON
+encoder/decoder based on the draft-12 specification for UBJSON.")
+ (license l:asl2.0)))