summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-02-05 14:52:02 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-19 11:39:43 +0100
commit9523fc798d0e30926fee52952be1583693e00275 (patch)
tree7251ad4dc5c9d39c7ed675eb17482da1fcb1bc47
parentfd166c3ecf3b298dea1ce2d85b5b886f4853e19d (diff)
downloadguix-patches-9523fc798d0e30926fee52952be1583693e00275.tar
guix-patches-9523fc798d0e30926fee52952be1583693e00275.tar.gz
gnu: Add rust-secrecy-0.6.
* gnu/packages/crates-io.scm (rust-secrecy-0.6): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a9aab38978..3e5b9959ff 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -52654,6 +52654,33 @@ statistical guarantees.")
(description "This package provides low-level bindings to libseccomp.")
(license license:lgpl2.1)))
+(define-public rust-secrecy-0.6
+ (package
+ (name "rust-secrecy")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "secrecy" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03q7h4yswpbrgxgn6wk9dyhilqhwcbhgwyy2m5vk9ps5ss72g0li"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-bytes" ,rust-bytes-0.5)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-zeroize" ,rust-zeroize-1))))
+ (home-page "https://github.com/iqlusioninc/crates/")
+ (synopsis "Wrapper types and traits for secret management")
+ (description
+ "This package provides wrapper types and traits for secret management
+which help ensure they aren't
+accidentally copied, logged, or otherwise exposed, and also ensure secrets
+are securely wiped from memory when dropped.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-section-testing-0.0
(package
(name "rust-section-testing")