summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-18 21:37:05 +0100
committerMarius Bakke <marius@gnu.org>2022-02-19 10:43:22 +0100
commit93cc9fb1408dd76ef7c38cbc011cb483880bcf5d (patch)
tree5b8e09bd727fa1a9f7c4f17d0fda32b3acbfa790
parent76c30931ad5e9a2b3383c6e5315bb00e0c0aa3b6 (diff)
downloadguix-patches-93cc9fb1408dd76ef7c38cbc011cb483880bcf5d.tar
guix-patches-93cc9fb1408dd76ef7c38cbc011cb483880bcf5d.tar.gz
gnu: xtl: Update to 0.7.4.
* gnu/packages/cpp.scm (xtl): Update to 0.7.4. [native-inputs]: Add DOCTEST. [arguments]: Remove trailing #t.
-rw-r--r--gnu/packages/cpp.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 86138531c0..07a0898a59 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -566,7 +566,7 @@ intuitive syntax and trivial integration.")
(define-public xtl
(package
(name "xtl")
- (version "0.6.23")
+ (version "0.7.4")
(source (origin
(method git-fetch)
(uri
@@ -575,20 +575,19 @@ intuitive syntax and trivial integration.")
(commit version)))
(sha256
(base32
- "1kd9zl4h6nrsg29hq13vwp4zhfj8sa90vj40726lpw6vxz48k4di"))
+ "134pgvmf9cx5dxs0m0m3qhp3m3r1gl86ic3xax21zc4sdj8sdq46"))
(file-name (git-file-name name version))))
(native-inputs
- (list googletest json-modern-cxx))
+ (list doctest googletest json-modern-cxx))
(arguments
- `(#:configure-flags
+ '(#:configure-flags
'("-DBUILD_TESTS=ON")
#:phases
(modify-phases %standard-phases
(replace 'check
(lambda* _
(with-directory-excursion "test"
- (invoke "./test_xtl")
- #t))))))
+ (invoke "./test_xtl")))))))
(home-page "https://github.com/QuantStack/xtl")
(build-system cmake-build-system)
(synopsis "C++ template library providing some basic tools")