summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-26 20:27:08 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:40 +0000
commit6a3d2369ebb0edc19de1ec739b219fecbc399c8b (patch)
tree281766392679f96777e450813b7d0f2eae7671e5
parent061187f670056f48b6f88aa3d539378c16cca27b (diff)
downloadguix-patches-6a3d2369ebb0edc19de1ec739b219fecbc399c8b.tar
guix-patches-6a3d2369ebb0edc19de1ec739b219fecbc399c8b.tar.gz
gnu: gnome-tweaks: Update to 40.0.
* gnu/packages/gnome.scm (gnome-tweaks): Update to 40.0. [source]: Fix the URI. [arguments]: Remove trailing #t. [native-inputs]: Add glib@bin.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ffb2146e17..f27811d7b3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9710,17 +9710,17 @@ existing databases over the internet.")
(define-public gnome-tweaks
(package
(name "gnome-tweaks")
- (version "3.34.1")
+ (version "40.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gnome-tweaks/"
- (version-major+minor version) "/"
+ (version-major version) "/"
"gnome-tweaks-" version ".tar.xz"))
(patches
(list (search-patch "gnome-tweaks-search-paths.patch")))
(sha256
(base32
- "19y62dj4n5i6v4zpjllxl51dch6ndy8xs45v5aqmmq9xyfrqk5yq"))))
+ "0sn3xsjhnini0f2dyi1ymrr3fb8mi7w5j5lsyw11rc5h67h3ypzr"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -9734,8 +9734,7 @@ existing databases over the internet.")
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "meson-postinstall.py"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-after 'install 'wrap
(@@ (guix build python-build-system) wrap))
(add-after 'wrap 'wrap-gi-typelib
@@ -9743,10 +9742,10 @@ existing databases over the internet.")
(let ((out (assoc-ref outputs "out"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH")))
(wrap-program (string-append out "/bin/gnome-tweaks")
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
- #t)))))
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))))))
(native-inputs
- `(("intltool" ,intltool)
+ `(("glib:bin" ,glib "bin") ; for glib-compile-resources, etc.
+ ("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
`(("gnome-desktop" ,gnome-desktop)