summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-18 21:37:47 +0100
committerMarius Bakke <marius@gnu.org>2022-02-19 10:43:22 +0100
commit4aae3774ca8944390e68ce78d313682bfbc72975 (patch)
tree758ac43cb1058080f7231f437671d8aeaeb518a7
parent93cc9fb1408dd76ef7c38cbc011cb483880bcf5d (diff)
downloadguix-patches-4aae3774ca8944390e68ce78d313682bfbc72975.tar
guix-patches-4aae3774ca8944390e68ce78d313682bfbc72975.tar.gz
gnu: xtensor: Update to 0.24.0.
* gnu/packages/algebra.scm (xtensor): Update to 0.24.0. [native-inputs]: Add DOCTEST. (xtensor-benchmark)[arguments]: Narrow substitution regex.
-rw-r--r--gnu/packages/algebra.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index a29451f8a2..0d34cfaf0f 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1139,7 +1139,7 @@ features, and more.")
(define-public xtensor
(package
(name "xtensor")
- (version "0.20.10")
+ (version "0.24.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1147,11 +1147,11 @@ features, and more.")
(commit version)))
(sha256
(base32
- "1fmv2hpx610xwhxrndfsfvlbqfyk4l3gi5q5d7pa9m82kblxjj9l"))
+ "14fpzwdq26p2fqdrmc78hny9pp09k9c53jnwlh7f8x54ikzm23c2"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
- (list googletest xtl))
+ (list doctest googletest xtl))
(arguments
`(#:configure-flags
'("-DBUILD_TESTS=ON")
@@ -1181,7 +1181,7 @@ xtensor provides:
(add-after 'unpack 'remove-march=native
(lambda _
(substitute* "benchmark/CMakeLists.txt"
- (("-march=native") ""))))
+ (("-march=native\"") "\""))))
(add-after 'unpack 'link-with-googlebenchmark
(lambda _
(substitute* "benchmark/CMakeLists.txt"