summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-11 21:49:38 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-11 21:49:38 +0200
commit45f5cae655a5ecdb7e8d1f5b30ab59102ac4ad76 (patch)
tree9f8f9f2295470c9f28ce4c364f00f675f06c6e9d
parent14d17788a942424fd1825d72b043f1b67e31900b (diff)
downloadguix-patches-45f5cae655a5ecdb7e8d1f5b30ab59102ac4ad76.tar
guix-patches-45f5cae655a5ecdb7e8d1f5b30ab59102ac4ad76.tar.gz
gnu: Add perl-io-tty.
* gnu/packages/perl.scm (perl-io-tty): New variable.
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f6a551fd0d..6279120107 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
@@ -102,3 +102,22 @@ lists of files")
provided base directory and can return files (and/or directories if desired)
matching a regular expression.")
(home-page "http://search.cpan.org/~dopacki/File-List/")))
+
+(define-public perl-io-tty
+ (package
+ (name "perl-io-tty")
+ (version "1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/T/TO/TODDR/IO-Tty-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1cgqyv1zg8857inlnfczrrgpqr0r6mmqv29b7jlmxv47s4df59ii"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/~toddr/IO-Tty/")
+ (synopsis "Perl interface to pseudo ttys")
+ (description
+ "This package provides the 'IO::Pty' and 'IO::Tty' Perl interfaces to
+pseudo ttys.")
+ (license (package-license perl))))