summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-18 21:40:24 +0100
committerMarius Bakke <marius@gnu.org>2022-02-19 10:43:23 +0100
commit2f6f9f2e544e5da8f11320559e16a0876ce4a05b (patch)
tree30e1dcc5095c9712c79c2cbb17972d19a74503f5
parentfb84285b7a9bc8e01048ed87e3215cabdf6fcae0 (diff)
downloadguix-patches-2f6f9f2e544e5da8f11320559e16a0876ce4a05b.tar
guix-patches-2f6f9f2e544e5da8f11320559e16a0876ce4a05b.tar.gz
gnu: python-scikit-image: Update to 0.19.1.
* gnu/packages/python-science.scm (python-scikit-image): Update to 0.19.1. [propagated-inputs]: Add PYTHON-PYTHRAN. [native-inputs]: Remove PYTHON-CODECOV, PYTHON-FLAKE8, PYTHON-PYTEST-COV, and PYTHON-WHEEL.
-rw-r--r--gnu/packages/python-science.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7b5ab44e0c..d9af3352b9 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -257,13 +257,13 @@ logic, also known as grey logic.")
(define-public python-scikit-image
(package
(name "python-scikit-image")
- (version "0.18.1")
+ (version "0.19.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "scikit-image" version))
(sha256
- (base32 "0wgisa03smhrphcjnhq7waa5vyyd32b67hblapjbqrqqj751idpv"))))
+ (base32 "0f0147jwkhx0w4s5r7w3drb7znzl2pgp4b0mdap1ha7cx3hhxw28"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -293,17 +293,14 @@ logic, also known as grey logic.")
python-networkx
python-numpy
python-pillow
+ python-pythran
python-pywavelets
python-scipy
python-tifffile))
(native-inputs
- (list python-codecov
- python-cython
- python-flake8
+ (list python-cython
python-pytest
- python-pytest-cov
- python-pytest-localserver
- python-wheel))
+ python-pytest-localserver))
(home-page "https://scikit-image.org/")
(synopsis "Image processing in Python")
(description