summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-18 21:31:11 +0100
committerMarius Bakke <marius@gnu.org>2022-02-19 10:43:22 +0100
commit144d9232bdaedb8f5ca29218b2b0e27ca62ae048 (patch)
tree002bc4a0819828407ac37afb444db033ee2b67af
parent57bfc7233b3e28a48c5c61938a2f533d2dac5356 (diff)
downloadguix-patches-144d9232bdaedb8f5ca29218b2b0e27ca62ae048.tar
guix-patches-144d9232bdaedb8f5ca29218b2b0e27ca62ae048.tar.gz
gnu: python-pyvo: Update to 1.2.1.
* gnu/packages/astronomy.scm (python-pyvo): Update to 1.2.1. [arguments]: Remove obsolete workaround.
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 7460b3d4d3..5336a9fb36 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -826,21 +826,20 @@ of astronomical sources.")
(define-public python-pyvo
(package
(name "python-pyvo")
- (version "1.2")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyvo" version))
(sha256
- (base32 "1lap703wxbyxqlbk85myirp4pkdnc6cg10xhfajfsvz5k0hm5ffw"))))
+ (base32 "1ri5yp6903386lkn79mdcmlax7zsfrrrjbcvb91wxydcc9yasc1n"))))
(build-system python-build-system)
(arguments
- `(#:phases
+ '(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
(invoke "python" "-m" "pytest" "--pyargs" "pyvo" "-k"
(string-append ; these tests use the network
"not test_access_with_string"