summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2018-02-18 22:08:15 -0500
committerMarius Bakke <mbakke@fastmail.com>2018-02-26 01:15:12 +0100
commit04ab38b7ee11bd6497fce6ce4bf4ebc689c1cff6 (patch)
tree62e97e165bd9fcf952ea314179e724c26337c8e7
parent1462b456577ca315dd910f52baaf1e7750d9f281 (diff)
downloadguix-patches-04ab38b7ee11bd6497fce6ce4bf4ebc689c1cff6.tar
guix-patches-04ab38b7ee11bd6497fce6ce4bf4ebc689c1cff6.tar.gz
gnu: ccl: Update to 1.11.5.
* gnu/packages/lisp.scm (ccl): Update to 1.11.5. [inputs]: Update ccl to its new hosting location. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/lisp.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 020abc7494..5f9a24500c 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -435,7 +435,7 @@ statistical profiler, a code coverage tool, and many other extensions.")
(define-public ccl
(package
(name "ccl")
- (version "1.11")
+ (version "1.11.5")
(source #f)
(build-system gnu-build-system)
;; CCL consists of a "lisp kernel" and "heap image", both of which are
@@ -448,7 +448,7 @@ statistical profiler, a code coverage tool, and many other extensions.")
,(origin
(method url-fetch)
(uri (string-append
- "ftp://ftp.clozure.com/pub/release/" version
+ "https://github.com/Clozure/ccl/releases/download/v" version
"/ccl-" version "-"
(match (%current-system)
((or "i686-linux" "x86_64-linux") "linuxx86")
@@ -461,9 +461,9 @@ statistical profiler, a code coverage tool, and many other extensions.")
(base32
(match (%current-system)
((or "i686-linux" "x86_64-linux")
- "0w3dmj7q9kqyra3yrf1lxclnjz151yvf5s5q8ayllvmvqbl8bs08")
+ "0hs1f3z7crgzvinpj990kv9gvbsipxvcvwbmk54n51nasvc5025q")
("armhf-linux"
- "1x487aaz2rqcb6k301sy2p39a1m4qdhg6z9p9fb76ssipqgr38b4")
+ "0p0l1dzsygb6i1xxgbipjpxkn46xhq3jm41a34ga1qqp4x8lkr62")
(_ ""))))))))
(native-inputs
`(("m4" ,m4)