summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-07-03 09:38:11 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-07-03 09:58:13 +0200
commit5a2997e5a60fdbabc720f88f8e6b2e237989b1b2 (patch)
tree8075ed5a3eda1e5cb195c913bd17bb75cbb7e58a
parent28febfafbb23561624cc5c4ac8ed581f1f867f70 (diff)
downloadguix-patches-5a2997e5a60fdbabc720f88f8e6b2e237989b1b2.tar
guix-patches-5a2997e5a60fdbabc720f88f8e6b2e237989b1b2.tar.gz
gnu: Add cl-bordeaux-fft.
* gnu/packages/lisp-xyz.scm (sbcl-bordeaux-fft, cl-bordeaux-fft, ecl-bordeaux-fft): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 97b5ec71e9..0519ac1532 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12236,3 +12236,33 @@ includes an implementation of Global Refinement of Random Forest.")
(define-public ecl-cl-random-forest
(sbcl-package->ecl-package sbcl-cl-random-forest))
+
+(define-public sbcl-bordeaux-fft
+ (let ((commit "4a1f5600cae59bdabcb32de4ee2d7d73a9450d6e")
+ (revision "0"))
+ (package
+ (name "sbcl-bordeaux-fft")
+ (version (git-version "1.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ahefner/bordeaux-fft.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j584w6kq2k6r8lp2i14f9605rxhp3r15s33xs08iz1pndn6iwqf"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "http://vintage-digital.com/hefner/software/bordeaux-fft/")
+ (synopsis "Fast Fourier Transform for Common Lisp")
+ (description
+ "The Bordeaux-FFT library provides a reasonably efficient implementation
+of the Fast Fourier Transform and its inverse for complex-valued inputs, in
+portable Common Lisp.")
+ (license license:gpl2+))))
+
+(define-public cl-bordeaux-fft
+ (sbcl-package->cl-source-package sbcl-bordeaux-fft))
+
+(define-public ecl-bordeaux-fft
+ (sbcl-package->ecl-package sbcl-bordeaux-fft))