summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:34:39 +0200
commitca1a015777565f1098d56ac3b5873226e50c067d (patch)
tree21d52f65189ae5ca4be068a1cfeec0014b52c56c
parentd2d1f8bfae5bd8b60178141a7199189356fd892e (diff)
downloadguix-patches-ca1a015777565f1098d56ac3b5873226e50c067d.tar
guix-patches-ca1a015777565f1098d56ac3b5873226e50c067d.tar.gz
gnu: r-genomicalignments: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-genomicalignments): Move from here... * gnu/packages/bioconductor.scm (r-genomicalignments): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm35
-rw-r--r--gnu/packages/bioinformatics.scm33
2 files changed, 34 insertions, 34 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b58c5bc11f..eef0811d4e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018, 2020, 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
@@ -2280,6 +2280,39 @@ translation between different chromosome sequence naming conventions (e.g.,
names in their natural, rather than lexicographic, order.")
(license license:artistic2.0)))
+(define-public r-genomicalignments
+ (package
+ (name "r-genomicalignments")
+ (version "1.26.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GenomicAlignments" version))
+ (sha256
+ (base32
+ "1q95px6s6snsax4ax955zzpdlrwp5liwf70wqq0lrk9mp6lq0hbr"))))
+ (properties
+ `((upstream-name . "GenomicAlignments")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-biostrings" ,r-biostrings)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)))
+ (home-page "https://bioconductor.org/packages/GenomicAlignments")
+ (synopsis "Representation and manipulation of short genomic alignments")
+ (description
+ "This package provides efficient containers for storing and manipulating
+short genomic alignments (typically obtained by aligning short reads to a
+reference genome). This includes read counting, computing the coverage,
+junction detection, and working with the nucleotide content of the
+alignments.")
+ (license license:artistic2.0)))
+
(define-public r-genomicranges
(package
(name "r-genomicranges")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2a7443314a..ba284759a0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7952,39 +7952,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-genomicalignments
- (package
- (name "r-genomicalignments")
- (version "1.26.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "GenomicAlignments" version))
- (sha256
- (base32
- "1q95px6s6snsax4ax955zzpdlrwp5liwf70wqq0lrk9mp6lq0hbr"))))
- (properties
- `((upstream-name . "GenomicAlignments")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)
- ("r-biocparallel" ,r-biocparallel)
- ("r-biostrings" ,r-biostrings)
- ("r-genomeinfodb" ,r-genomeinfodb)
- ("r-genomicranges" ,r-genomicranges)
- ("r-iranges" ,r-iranges)
- ("r-rsamtools" ,r-rsamtools)
- ("r-s4vectors" ,r-s4vectors)
- ("r-summarizedexperiment" ,r-summarizedexperiment)))
- (home-page "https://bioconductor.org/packages/GenomicAlignments")
- (synopsis "Representation and manipulation of short genomic alignments")
- (description
- "This package provides efficient containers for storing and manipulating
-short genomic alignments (typically obtained by aligning short reads to a
-reference genome). This includes read counting, computing the coverage,
-junction detection, and working with the nucleotide content of the
-alignments.")
- (license license:artistic2.0)))
-
(define-public r-rtracklayer
(package
(name "r-rtracklayer")