summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-04-30 19:09:00 +0000
committerEfraim Flashner <efraim@flashner.co.il>2017-08-01 20:57:51 +0300
commitf2e1271809f0aaf33ff1afa082bf2e00af8633cf (patch)
tree6832192e14ae692af349f21ef0998dbef78b86a4
parent89c9445aa27036a13ed485c0f5eda59314152927 (diff)
downloadguix-patches-f2e1271809f0aaf33ff1afa082bf2e00af8633cf.tar
guix-patches-f2e1271809f0aaf33ff1afa082bf2e00af8633cf.tar.gz
gnu: Add pidentd.
* gnu/packages/networking.scm (pidentd): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/networking.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5f555ee67f..6dd6046461 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2016, 2017 ng0 <ng0@libertad.pw>
+;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 Benz Schenk <benz.schenk@uzh.ch>
;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
@@ -1270,6 +1270,32 @@ enabled due to license conflicts between the BSD advertising clause and the GPL.
;; distribution for clarification.
(license (list license:bsd-3 license:bsd-4))))
+(define-public pidentd
+ (package
+ (name "pidentd")
+ (version "3.0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ptrrkssn/pidentd/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0y3kd1bkydqkpc1qdff24yswysamsqivvadjy0468qri5730izgc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; No tests are included
+ (inputs
+ `(("openssl" ,openssl))) ; For the DES library
+ (home-page "https://www.lysator.liu.se/~pen/pidentd/")
+ (synopsis "Small Ident Daemon")
+ (description
+ "@dfn{Pidentd} (Peter's Ident Daemon) is a identd, which implements a
+identification server. Pidentd looks up specific TCP/IP connections and
+returns the user name and other information about the connection.")
+ (license license:public-domain)))
+
(define-public spiped
(package
(name "spiped")