summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-26 07:27:31 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:36 +0000
commita1ab329f33c666aa1eaa7444320b641487b8419c (patch)
treef8233661df0b9e51408e58d23fc426b6b1b37076
parent2e261e7ab8517876b771bbb51acf4324317c5cf0 (diff)
downloadguix-patches-a1ab329f33c666aa1eaa7444320b641487b8419c.tar
guix-patches-a1ab329f33c666aa1eaa7444320b641487b8419c.tar.gz
gnu: libgdata: Update to 0.18.1.
* gnu/packages/gnome.scm (libgdata): Update to 0.18.1. [build-system]: Switch to meson-build-system. [arguments]: Remove the 'disable-failing-tests phase. [native-inputs]: Add gobject-introspection. [inputs]: Add vala.
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7012839fae..2d643343cb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1969,12 +1969,10 @@ relationship modeling, and network diagrams. The program supports various file
formats like PNG, SVG, PDF and EPS.")
(license license:gpl2+))))
-;; This is the unstable release, but it is required for the current stable
-;; release of gvfs (1.38.1).
(define-public libgdata
(package
(name "libgdata")
- (version "0.17.9")
+ (version "0.18.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1982,29 +1980,25 @@ formats like PNG, SVG, PDF and EPS.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0fj54yqxdapdppisqm1xcyrpgcichdmipq0a0spzz6009ikzgi45"))))
- (build-system gnu-build-system)
+ "1iq4d1qy0vkmy29xvr13dgz4pxvn5v3yi2swryld0ajinvp951fx"))))
+ (build-system meson-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-before 'check 'set-home-for-tests
(lambda _
- (setenv "HOME" "/tmp")))
- (add-before 'check 'disable-failing-tests
- (lambda _
- ;; The PicasaWeb API tests fail with gnome-online-accounts@3.24.2.
- ;; They have been removed in libgdata 0.17.6, so just do the same.
- (substitute* "gdata/tests/Makefile"
- (("picasaweb\\$\\(EXEEXT\\) ") "")))))))
+ (setenv "HOME" "/tmp"))))))
(native-inputs
`(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("uhttpmock" ,uhttpmock)))
(inputs
`(("cyrus-sasl" ,cyrus-sasl)
- ("glib-networking" ,glib-networking)))
+ ("glib-networking" ,glib-networking)
+ ("vala" ,vala)))
(propagated-inputs
`(("gcr" ,gcr)
("glib" ,glib)