summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2021-09-27 02:20:17 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-15 17:55:50 +0100
commit93730073219fa3da6558c90ac9b14064727f4916 (patch)
tree89a98b650afbc2d21d1d44349224b3c5fb28c5da
parent0ace339cbeb01552a496397a547c6c782ad8f2c8 (diff)
downloadguix-patches-93730073219fa3da6558c90ac9b14064727f4916.tar
guix-patches-93730073219fa3da6558c90ac9b14064727f4916.tar.gz
gnu: Add python-logical-unification.
* gnu/packages/python-xyz.scm (python-logical-unification): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bc1f6bc2b7..ece7e7bf2f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27400,6 +27400,27 @@ graph can be output for rendering by GraphViz or yEd.")
function implementations based on the types of the arguments.")
(license license:bsd-3)))
+(define-public python-logical-unification
+ (package
+ (name "python-logical-unification")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "logical-unification" version))
+ (sha256
+ (base32
+ "0j57953hi7kg2rl0163vzjzsvzdyjimnklhx6idf5vaqqf1d3p1j"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-multipledispatch" ,python-multipledispatch)
+ ("python-toolz" ,python-toolz)))
+ (home-page "https://github.com/pythological/unification/")
+ (synopsis "Logical unification in Python for solving symbolic expressions")
+ (description "This library provides algorithms and data types for solving
+symbolic expressions in pure Python using the technique of logical unification.")
+ (license license:bsd-3)))
+
(define-public date2name
(let ((commit "6c8f37277e8ec82aa50f90b8921422be30c4e798")
(revision "1"))