summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-11-14 18:03:41 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-11-14 18:03:41 -0800
commit272e8f50511a551ce1c0a941c949c8ffafd849ff (patch)
tree613086916afba22e6ba04475026c87eb249facfb
parentc9b171f46b75665cd475c594f97f663243e21ed1 (diff)
parent75cae188ad6e911564c1c7984680bb431793ff18 (diff)
downloadguix-patches-272e8f50511a551ce1c0a941c949c8ffafd849ff.tar
guix-patches-272e8f50511a551ce1c0a941c949c8ffafd849ff.tar.gz
Merge branch 'typo-fixes-20211114'
-rw-r--r--gnu/home/services.scm2
-rw-r--r--gnu/home/services/shells.scm2
-rw-r--r--gnu/home/services/utils.scm2
-rw-r--r--gnu/home/services/xdg.scm2
-rw-r--r--gnu/packages/bioconductor.scm2
-rw-r--r--gnu/packages/crates-io.scm2
-rw-r--r--gnu/packages/emacs-xyz.scm2
-rw-r--r--gnu/packages/haskell-check.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/scanner.scm2
-rw-r--r--guix/build/qt-utils.scm2
11 files changed, 11 insertions, 11 deletions
diff --git a/gnu/home/services.scm b/gnu/home/services.scm
index df1a3a19e2..992e522fa2 100644
--- a/gnu/home/services.scm
+++ b/gnu/home/services.scm
@@ -351,7 +351,7 @@ extended with one gexp.")))
(unless new-home-env (setenv "GUIX_NEW_HOME" #f))
(unless old-home-env (setenv "GUIX_OLD_HOME" #f)))
(format #t "\
-Activation script was either called or loaded by file from this direcotry:
+Activation script was either called or loaded by file from this directory:
~a
It doesn't seem that home environment is somewhere around.
Make sure that you call ./activate by symlink from -home store item.\n"
diff --git a/gnu/home/services/shells.scm b/gnu/home/services/shells.scm
index 81d07da86c..6b9ebe42e9 100644
--- a/gnu/home/services/shells.scm
+++ b/gnu/home/services/shells.scm
@@ -69,7 +69,7 @@ only be extended.
@code{profile} is a list of file-like objects, which will go to
@file{~/.profile}. By default @file{~/.profile} contains the
initialization code, which have to be evaluated by login shell to make
-home-environment's profile avaliable to the user, but other commands
+home-environment's profile available to the user, but other commands
can be added to the file if it is really necessary.
In most cases shell's configuration files are preferred places for
diff --git a/gnu/home/services/utils.scm b/gnu/home/services/utils.scm
index cea75ee896..3ce32f80c0 100644
--- a/gnu/home/services/utils.scm
+++ b/gnu/home/services/utils.scm
@@ -28,7 +28,7 @@
list->human-readable-list))
(define (maybe-object->string object)
- "Like @code{object->string} but don't do anyting if OBJECT already is
+ "Like @code{object->string} but don't do anything if OBJECT already is
a string."
(if (string? object)
object
diff --git a/gnu/home/services/xdg.scm b/gnu/home/services/xdg.scm
index 20fb7f7b40..d230dd7665 100644
--- a/gnu/home/services/xdg.scm
+++ b/gnu/home/services/xdg.scm
@@ -136,7 +136,7 @@ are no extensions use configuration instead."
(description "Configure XDG base directories. This
service introduces two additional variables @env{XDG_STATE_HOME},
@env{XDG_LOG_HOME}. They are not a part of XDG specification, at
-least yet, but are convinient to have, it improves the consistency
+least yet, but are convenient to have, it improves the consistency
between different home services. The services of this service-type is
instantiated by default, to provide non-default value, extend the
service-type (using @code{simple-service} for example).")))
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 47bfa11e68..d36d070a56 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -13123,7 +13123,7 @@ within the R for Mass Spectrometry packages.")
"The MsFeature package defines functionality for Mass Spectrometry
features. This includes functions to group (LC-MS) features based on some of
their properties, such as retention time (coeluting features), or correlation
-of signals across samples. This packge hence allows to group features, and
+of signals across samples. This package hence allows to group features, and
its results can be used as an input for the @code{QFeatures} package which
allows to aggregate abundance levels of features within each group. This
package defines concepts and functions for base and common data types,
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index aa5cdef1e2..9f9014b9ce 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17405,7 +17405,7 @@ a result when an allocation error occurs, ala
@url{https://github.com/rust-lang/rfcs/blob/master/text/2116-alloc-me-maybe.md,RFC
2116}. The API currently proposes a fallible interface for @code{Vec},
@code{Box}, @code{Arc}, @code{Btree} and @code{Rc}, as well as a
-@code{TryClone} trait wich is implemented for primitive Rust traits and a
+@code{TryClone} trait which is implemented for primitive Rust traits and a
fallible format macro.")
(license (list license:expat license:asl2.0))))
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b305bb5386..7e49fcbf5f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12360,7 +12360,7 @@ programming and reproducible research.")
(synopsis "Unmaintained add-ons for Org mode")
(description
"This package contains add-ons to Org. Be warned that these libraries
-receive little if no maintainance and there is no guaranty that they are
+receive little if no maintenance and there is no guaranty that they are
compatible with the Org stable version.")
(license license:gpl3+)))
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 04d9ff6253..90ef3236b6 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -1120,7 +1120,7 @@ examples and more information.")
(home-page "https://github.com/andrewthad/quickcheck-classes#readme")
(synopsis "QuickCheck common typeclasses from `base`")
(description
- "This libary is a minimal variant of `quickcheck-classes`
+ "This library is a minimal variant of `quickcheck-classes`
that only provides laws for typeclasses from `base`. The main
purpose of splitting this out is so that `primitive` can depend
on `quickcheck-classes-base` in its test suite, avoiding the
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ea5ad8e8ce..3d34ea4ba7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3434,7 +3434,7 @@ with sensible defaults out of the box.")
(native-inputs
`(("python-pytest-cov" ,python-pytest-cov)))
(home-page "https://github.com/mapbox/cligj")
- (synopsis "Click params for commmand line interfaces to GeoJSON")
+ (synopsis "Click params for command line interfaces to GeoJSON")
(description
"cligj is for Python developers who create command line interfaces
for geospatial data. cligj allows you to quickly build consistent,
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index 00d094cc4b..9d4abe88c6 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -240,7 +240,7 @@ package contains the library and drivers.")))
("zlib" ,zlib)))
(home-page "https://scanbd.sourceforge.io")
(synopsis "Configurable scanner button monitor")
- (description "Scanbd stands for scanner button daemon. It regulary polls
+ (description "Scanbd stands for scanner button daemon. It regularly polls
scanners for pressed buttons, function knob changes, or other events such
as (un)plugging the scanner or inserting and removing paper. Then it performs
the desired action(s) such as saving, copying, or e-mailing the image.
diff --git a/guix/build/qt-utils.scm b/guix/build/qt-utils.scm
index c2b80cab7d..5d3a4d22e6 100644
--- a/guix/build/qt-utils.scm
+++ b/guix/build/qt-utils.scm
@@ -109,7 +109,7 @@
(define* (wrap-qt-program program-name #:key inputs output
(qt-wrap-excluded-inputs %qt-wrap-excluded-inputs))
- "Wrap the specified programm (which must reside in the OUTPUT's \"/bin\"
+ "Wrap the specified program (which must reside in the OUTPUT's \"/bin\"
directory) with suitably set environment variables.
This is like qt-build-systems's phase \"qt-wrap\", but only the named program