summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2018-07-16 13:22:28 -0400
committerLeo Famulari <leo@famulari.name>2018-07-17 17:58:18 -0400
commit5691898f28cd2e24c14de28c45f25bf3b03b1c41 (patch)
treefc4beddeaa2a21a79a9cf3e97d0b4cda9b2bb53c
parent16dc5ed0396a2edfb4e7f729ec43392c74ebdc7a (diff)
downloadguix-patches-5691898f28cd2e24c14de28c45f25bf3b03b1c41.tar
guix-patches-5691898f28cd2e24c14de28c45f25bf3b03b1c41.tar.gz
gnu: Add emacs-markup-faces
* gnu/packages/emacs.scm (emacs-markup-faces): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 20d5597f5f..726792155d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2018 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11475,3 +11476,25 @@ can do different things depending on the context. In this package, it means
that, if the cursor is in a currently hidden folded construction, we want to
show it; if it's not, we want to hide whatever fold the cursor is in.")
(license license:gpl2+))))
+
+(define-public emacs-markup-faces
+ (package
+ (name "emacs-markup-faces")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://stable.melpa.org/packages/markup-faces-"
+ version ".el"))
+ (sha256
+ (base32
+ "124dxbaa25fwxnpwsygpz7pw6da6dnnw7y2lic3jf8rgz7lw4v32"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/sensorflo/markup-faces")
+ (synopsis "Collection of Emacs faces for markup language modes")
+ (description "emacs-markup-faces is like font-lock-faces, but tailored for
+markup languages instead programming languages. The sub group markup-faces-text
+is also intended for 'text viewing modes' such as info or (wo)man. This gives a
+common look and feel, or let's say theme, across different markup language modes
+and 'text viewing modes' respectively.")
+ (license license:gpl3+)))