summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-12-17 23:10:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-12-17 23:13:43 +0100
commitfcf1702196bc7203a15998fb152d7ccadfe3b7ce (patch)
tree761bc574bd772d2a2078715eb0f01a4328940717
parent43c1c4b65fe6134664447516274cd656802e13f4 (diff)
downloadguix-patches-fcf1702196bc7203a15998fb152d7ccadfe3b7ce.tar
guix-patches-fcf1702196bc7203a15998fb152d7ccadfe3b7ce.tar.gz
gnu: sudo: Update to 1.9.4p1.
* gnu/packages/admin.scm (sudo): Update to 1.9.4p1. [source]: Remove patch. * gnu/packages/patches/sudo-fix-build-without-sendmail.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/admin.scm5
-rw-r--r--gnu/packages/patches/sudo-fix-build-without-sendmail.patch45
3 files changed, 2 insertions, 49 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index aef413abdf..98590ae8eb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1449,7 +1449,6 @@ dist_patch_DATA = \
%D%/packages/patches/sdl-pango-matrix_declarations.patch \
%D%/packages/patches/sdl-pango-sans-serif.patch \
%D%/packages/patches/sqlite-hurd.patch \
- %D%/packages/patches/sudo-fix-build-without-sendmail.patch \
%D%/packages/patches/sunxi-tools-remove-sys-io.patch \
%D%/packages/patches/patchutils-test-perms.patch \
%D%/packages/patches/patch-hurd-path-max.patch \
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 90b09f752d..8f377ea72c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1398,7 +1398,7 @@ system administrator.")
(define-public sudo
(package
(name "sudo")
- (version "1.9.4")
+ (version "1.9.4p1")
(source (origin
(method url-fetch)
(uri
@@ -1408,8 +1408,7 @@ system administrator.")
version ".tar.gz")))
(sha256
(base32
- "1w03257akspgkkl757vmpq3p30sb2n6y61hll038mw9sqwnbv4cb"))
- (patches (search-patches "sudo-fix-build-without-sendmail.patch"))
+ "0xyn5z4npg6nmjmgglp7db9sn82rkx52fg1sw6bs8byxzjfhjwhi"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/sudo-fix-build-without-sendmail.patch b/gnu/packages/patches/sudo-fix-build-without-sendmail.patch
deleted file mode 100644
index f40bfe445e..0000000000
--- a/gnu/packages/patches/sudo-fix-build-without-sendmail.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-
-# HG changeset patch
-# User Todd C. Miller <Todd.Miller@sudo.ws>
-# Date 1606767492 25200
-# Node ID 41db1aad85bbce444b511bcb28b9628a0a22fcd9
-# Parent 96a5cfe3c66b6ee84d7f7b6fb26d932f45a44b76
-Fix build when configured using --without-sendmail
-Bug #947
-
-diff -r 96a5cfe3c66b -r 41db1aad85bb lib/eventlog/eventlog.c
---- a/lib/eventlog/eventlog.c Sun Nov 29 15:11:34 2020 -0700
-+++ b/lib/eventlog/eventlog.c Mon Nov 30 13:18:12 2020 -0700
-@@ -78,7 +78,7 @@
- static FILE *eventlog_stub_open_log(int type, const char *logfile);
- static void eventlog_stub_close_log(int type, FILE *fp);
-
--/* Eventlog config settings */
-+/* Eventlog config settings (default values). */
- static struct eventlog_config evl_conf = {
- EVLOG_NONE, /* type */
- EVLOG_SUDO, /* format */
-@@ -91,7 +91,11 @@
- false, /* omit_hostname */
- _PATH_SUDO_LOGFILE, /* logpath */
- "%h %e %T", /* time_fmt */
-+#ifdef _PATH_SUDO_SENDMAIL
- _PATH_SUDO_SENDMAIL, /* mailerpath */
-+#else
-+ NULL, /* mailerpath (disabled) */
-+#endif
- "-t", /* mailerflags */
- NULL, /* mailfrom */
- MAILTO, /* mailto */
-@@ -1436,8 +1440,10 @@
- evl_conf.logpath = _PATH_SUDO_LOGFILE;
- if (evl_conf.time_fmt == NULL)
- evl_conf.time_fmt = "%h %e %T";
-+#ifdef _PATH_SUDO_SENDMAIL
- if (evl_conf.mailerpath == NULL)
- evl_conf.mailerpath = _PATH_SUDO_SENDMAIL;
-+#endif
- if (evl_conf.mailerflags == NULL)
- evl_conf.mailerflags = "-t";
- if (evl_conf.mailto == NULL)
-