summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-14 23:30:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-15 09:45:28 +0200
commit538fe01934c38ebe06e6b68d805e410694191f49 (patch)
tree823ccd8d9b99688e26d0ef07d991293fcaa2328f
parent1f781865fb609f529752ff4d285c24c98a77912e (diff)
downloadguix-patches-538fe01934c38ebe06e6b68d805e410694191f49.tar
guix-patches-538fe01934c38ebe06e6b68d805e410694191f49.tar.gz
gnu: python-vcversioner: Update to 2.16.0.0.
* gnu/packages/python.scm (python-vcversioner): Update to 2.16.0.0. [inputs]: Remove python-setuptools. [properties]: New field. (python2-vcversioner): Use 'strip-python2-variant'. [native-inputs]: Add python2-setuptools.
-rw-r--r--gnu/packages/python.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e880ad8c78..18e485ab2e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2486,26 +2486,29 @@ than Python’s urllib2 library.")
(define-public python-vcversioner
(package
(name "python-vcversioner")
- (version "2.14.0.0")
+ (version "2.16.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "vcversioner" version))
(sha256
(base32
- "11ivq1bm7v0yb4nsfbv9m7g7lyjn112gbvpjnjz8nv1fx633dm5c"))))
+ "16z10sm78jd7ca3jbkgc3q5i8a8q7y1h21q1li21yy3rlhbhrrns"))))
(build-system python-build-system)
- (inputs
- `(("python-setuptools" ,python-setuptools)))
(synopsis "Python library for version number discovery")
(description "Vcversioner is a Python library that inspects tagging
information in a variety of version control systems in order to discover
version numbers.")
(home-page "https://github.com/habnabit/vcversioner")
- (license license:isc)))
+ (license license:isc)
+ (properties `((python2-variant . ,(delay python2-vcversioner))))))
(define-public python2-vcversioner
- (package-with-python2 python-vcversioner))
+ (let ((vcversioner (package-with-python2
+ (strip-python2-variant python-vcversioner))))
+ (package (inherit vcversioner)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs vcversioner))))))
(define-public python-jsonschema
(package