summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 11:36:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:20 +0300
commit736eecd52dc29fcf06127c8fa26d884251f6e778 (patch)
tree9decd023a869fad47f9be3db35fdfffc544a6733
parent25ece40ef7e95d7872665a809231a99f4d79f3fc (diff)
downloadguix-patches-736eecd52dc29fcf06127c8fa26d884251f6e778.tar
guix-patches-736eecd52dc29fcf06127c8fa26d884251f6e778.tar.gz
gnu: Add julia-intervalsets.
* gnu/packages/julia-xyz.scm (julia-intervalsets): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 8e82f5e847..9d7601ce06 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1571,6 +1571,32 @@ indexed images, sometimes called \"colormap images\" or \"paletted images.\"")
interfaces with @file{.ini} files.")
(license license:expat)))
+(define-public julia-intervalsets
+ (package
+ (name "julia-intervalsets")
+ (version "0.5.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaMath/IntervalSets.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gsz89cd3iygbl5qr389k9vwpg7w1nk0s90g25nsmk34y9hifxag"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-ellipsisnotation" ,julia-ellipsisnotation)))
+ (native-inputs
+ `(("julia-offsetarrays" ,julia-offsetarrays)))
+ (home-page "https://github.com/JuliaMath/IntervalSets.jl")
+ (synopsis "Interval Sets for Julia")
+ (description "This package is intended to implement a \"minimal\" foundation
+for intervals upon which other packages might build. In particular, we
+encourage type-piracy for the reason that only one interval package can
+unambiguously define the @code{..} and @code{±} operators.")
+ (license license:expat)))
+
(define-public julia-invertedindices
(package
(name "julia-invertedindices")