summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-09-04 15:09:30 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-09-07 08:27:57 -0400
commit468e56576c23c44b96f0af08e15bd302862f9c81 (patch)
treec799b878ed6b3ae06456f8dc8a1082c108168a9e
parent4a9e05856622d535cb51d64fe733b1c904095516 (diff)
downloadguix-patches-468e56576c23c44b96f0af08e15bd302862f9c81.tar
guix-patches-468e56576c23c44b96f0af08e15bd302862f9c81.tar.gz
gnu: Add ruby-byebug.
* gnu/packages/ruby.scm (ruby-byebug): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5ec32b4d02..1e9ed271f7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1057,3 +1057,26 @@ alternative to Marshal for Object serialization. ")
with PostgreSQL 8.4 and later.")
(home-page "https://bitbucket.org/ged/ruby-pg")
(license license:ruby)))
+
+(define-public ruby-byebug
+ (package
+ (name "ruby-byebug")
+ (version "6.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "byebug" version))
+ (sha256
+ (base32
+ "0537h9qbhr6csahmzyn4lk1g5b2lcligbzd21gfy93nx9lbfdnzc"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; no tests
+ (synopsis "Debugger for Ruby 2")
+ (description "Byebug is a Ruby 2 debugger implemented using the Ruby 2
+TracePoint C API for execution control and the Debug Inspector C API for call
+stack navigation. The core component provides support that front-ends can
+build on. It provides breakpoint handling and bindings for stack frames among
+other things and it comes with a command line interface.")
+ (home-page "http://github.com/deivid-rodriguez/byebug")
+ (license license:bsd-2)))