summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-05 21:25:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-05 21:51:03 +0300
commit0cae36b5e5bd88eefea30b122acd41290a966980 (patch)
tree174c567baea4f07409728b6970c9d945280dc346
parentb100a704955432b6287b62add3bd3e9ccd94f002 (diff)
downloadguix-patches-0cae36b5e5bd88eefea30b122acd41290a966980.tar
guix-patches-0cae36b5e5bd88eefea30b122acd41290a966980.tar.gz
gnu: libmediainfo: Adjust build phases.
* gnu/packages/video.scm (libmediainfo)[arguments]: Change to the build directory before running autogen.
-rw-r--r--gnu/packages/video.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3924e93f96..ab755347d3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2250,10 +2250,11 @@ practically any type of media.")
#:phases
;; build scripts not in root of archive
(modify-phases %standard-phases
- (add-before 'configure 'pre-configure
+ (add-after 'unpack 'change-to-build-dir
(lambda _
- (chdir "Project/GNU/Library")))
- (add-after 'unpack 'autogen
+ (chdir "Project/GNU/Library")
+ #t))
+ (add-after 'change-to-build-dir 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh")))))))
(home-page "https://mediaarea.net/en/MediaInfo")