summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Saavedra <rennes@openmailbox.org>2016-01-27 20:07:12 +0100
committer宋文武 <iyzsong@gmail.com>2016-01-29 08:36:07 +0800
commitc3f29bc928d5900971f65965feaae59e1272a3f7 (patch)
tree922ab7ddcbc037cdedee6d863be026c943d03758
parentf88f0d20e439012e1a86b5ec14255a449d057200 (diff)
downloadguix-patches-c3f29bc928d5900971f65965feaae59e1272a3f7.tar
guix-patches-c3f29bc928d5900971f65965feaae59e1272a3f7.tar.gz
gnu: Add gtk-vnc.
* gnu/packages/gnome.scm (gtk-vnc): New variable. Co-authored-by: 宋文武 <iyzsong@gmail.com>
-rw-r--r--gnu/packages/gnome.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 05efe0ba97..b480235bc1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -45,6 +45,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages cups)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
#:use-module (gnu packages djvu)
#:use-module (gnu packages dns)
@@ -4565,3 +4566,41 @@ properties, screen resolution, and other GNOME parameters.")
"GNOME Shell provides core user interface functions for the GNOME desktop,
like switching to windows and launching applications.")
(license license:gpl2+)))
+
+(define-public gtk-vnc
+ (package
+ (name "gtk-vnc")
+ (version "0.5.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1rwwdh7lb16xdmy76ca6mpqfc3zfl3a4bkcr0qb6hs6ffrxak2j8"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--with-gtk=3.0")))
+ (propagated-inputs
+ `(("gtk+" ,gtk+))) ; required by gtk-vnc-2.0.pc.
+ (inputs
+ `(("cyrus-sasl" ,cyrus-sasl)
+ ("gnutls" ,gnutls)
+ ("libgcrypt" ,libgcrypt)
+ ("pulseaudio" ,pulseaudio)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (home-page "https://wiki.gnome.org/Projects/gtk-vnc")
+ (synopsis "VNC viewer widget for GTK+")
+ (description
+ "GTK-VNC is a VNC viewer widget for GTK+, used by remote desktop viewing
+applications, for instance the Vinagre client, GNOME Boxes and virt-viewer.
+GTK-VNC implements client side RFB protocol and authentication extensions such
+as SASL, TLS and VeNCrypt. Additionally it supports encoding extensions.")
+ (license license:lgpl2.1+)))