summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-12 09:13:14 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:27:20 -0400
commitcd01e36d8a7c1398946b1ccedaaeab31eda498e3 (patch)
tree74f156c3f7299db21fa614b0b144d6e737965af4
parentde40b569427d94fb236a8d00aaf53636a393fb72 (diff)
downloadguix-patches-cd01e36d8a7c1398946b1ccedaaeab31eda498e3.tar
guix-patches-cd01e36d8a7c1398946b1ccedaaeab31eda498e3.tar.gz
gnu: gtk-doc: Enable help.
* gnu/packages/gtk.scm (gtk-doc) [outputs]: New output 'help'. [arguments]<#:configure-flags>[--with-help-dir]: New flag. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2322b5c627..4d3017da73 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1743,6 +1743,7 @@ information.")
(base32
"0z4h1dggpimygdp719l457jvqilps4qcfpk31jmj3jqpzcsg03ny"))))
(build-system glib-or-gtk-build-system)
+ (outputs '("out" "help"))
(arguments
`(#:parallel-tests? #f
#:phases
@@ -1799,7 +1800,10 @@ information.")
#:configure-flags
(list (string-append "--with-xml-catalog="
(assoc-ref %build-inputs "docbook-xml")
- "/xml/dtd/docbook/catalog.xml"))))
+ "/xml/dtd/docbook/catalog.xml")
+ (string-append "--with-help-dir="
+ (assoc-ref %outputs "help")
+ "/share/help"))))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")