summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-20 18:46:15 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-20 19:41:57 +0200
commitc812f46058ad7f4baedd521ad4f0933737d82ae9 (patch)
tree614ca571d758234cf447947e37c610de56785634
parent6779ae27e62ab390b970944c74fb910028a40530 (diff)
downloadguix-patches-c812f46058ad7f4baedd521ad4f0933737d82ae9.tar
guix-patches-c812f46058ad7f4baedd521ad4f0933737d82ae9.tar.gz
gnu: Add aegisub.
* gnu/packages/video.scm (aegisub): New variable.
-rw-r--r--gnu/packages/video.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0605c1467e..43e4fc2eb5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -85,6 +85,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages libreoffice)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages m4)
@@ -2415,3 +2416,59 @@ programmers to access a standard API to open and decompress media files.")
;; sources are distributed under a different license that the binary.
;; see https://github.com/FFMS/ffms2/blob/master/COPYING
(license license:gpl2+))); inherits from ffmpeg
+
+(define-public aegisub
+ (package
+ (name "aegisub")
+ (version "3.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://ftp.aegisub.org/pub/archives/releases/source/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "11b83qazc8h0iidyj1rprnnjdivj1lpphvpa08y53n42bfa36pn5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-update-checker"
+ "--without-portaudio"
+ "--without-openal"
+ "--without-oss")
+ ;; tests require busted, a lua package we don't have yet
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-ldflags
+ (lambda _
+ (setenv "LDFLAGS" "-pthread"))))))
+ (inputs
+ `(("boost" ,boost)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("ffms2" ,ffms2)
+ ("fftw" ,fftw)
+ ("hunspell" ,hunspell)
+ ("mesa" ,mesa)
+ ("libass" ,libass)
+ ("alsa-lib" ,alsa-lib)
+ ("pulseaudio" ,pulseaudio)
+ ("libx11" ,libx11)
+ ("freetype" ,freetype)
+ ("wxwidgets-gtk2" ,wxwidgets-gtk2)))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://www.aegisub.org/")
+ (synopsis "Subtitle engine")
+ (description
+ "Aegisub is a tool for creating and modifying subtitles. Aegisub makes
+it quick and easy to time subtitles to audio, and features many powerful
+tools for styling them, including a built-in real-time video preview.")
+ (license (list license:bsd-3 ; the package is licensed under the bsd-3, except
+ license:mpl1.1 ; for vendor/universalchardet under the mpl1.1
+ license:expat)))) ; and src/gl that is under a license similar
+ ; the the Expat license, with a rewording (Software -> Materials). (called MIT
+ ; by upstream). See https://github.com/Aegisub/Aegisub/blob/master/LICENCE
+ ; src/MatroskaParser.(c|h) is under bsd-3 with permission from the author
+