summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-12-04 01:02:00 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:27:21 -0400
commitbb8be806b5e6bcbe83ae1ebfce71a3881cf23015 (patch)
treefbca1262a56155f303d9654c8f35b82d7beb98a2
parentcccbe0a7cb80b10aec32a12236fff5045d791fa5 (diff)
downloadguix-patches-bb8be806b5e6bcbe83ae1ebfce71a3881cf23015.tar
guix-patches-bb8be806b5e6bcbe83ae1ebfce71a3881cf23015.tar.gz
gnu: cairo: Enable some features.
* gnu/packages/gtk.scm (cairo) [native-inputs]: Add gobject-introspection. [inputs]: Add libdrm. Remove xorgproto and zlib. [propagated-inputs]: Add libxcb. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm39
1 files changed, 27 insertions, 12 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 6dd281e2bc..f1f71c2612 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -139,30 +139,45 @@ tools have full access to view and control running applications.")
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
#:configure-flags
(list
- "--enable-tee" ;needed for GNU Icecat
- "--enable-xml" ;for cairo-xml support
"--disable-static"
+ ;; XXX: To be enabled.
+ ;; "--enable-gallium=yes"
+ ;; "--enable-gl=yes"
+ ;; " --enable-glesv2=yes"
+ ;; "--enable-glesv3=yes"
+ ;; "--enable-cogl=yes"
+ ;; "--enable-directfb=yes"
+ ;; "--enable-vg=yes"
+ "--enable-tee=yes"
+ "--enable-xml=yes"
(string-append "--with-html-dir="
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
- `(("ghostscript" ,ghostscript)
+ `(("drm" ,libdrm)
+ ("ghostscript" ,ghostscript)
("libspectre" ,libspectre)
- ("poppler" ,poppler)
- ("xorgproto" ,xorgproto)
- ("zlib" ,zlib)))
+ ("poppler" ,poppler)))
(propagated-inputs
- `(("fontconfig" ,fontconfig)
+ `( ;; ("cogl" ,cogl)
+ ;; ("directfb" ,directfb)
+ ("fontconfig" ,fontconfig)
+ ("fontconfig" ,fontconfig)
("freetype" ,freetype)
("glib" ,glib)
+ ;; ("gtk+" ,gtk+)
("libpng" ,libpng)
- ("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxrender" ,libxrender)
- ("pixman" ,pixman)))
+ ;; ("librsvg" ,librsvg)
+ ;; ("opengl" ,mesa)
+ ("pixman" ,pixman)
+ ("x11" ,libx11)
+ ("xcb" ,libxcb)
+ ("xext" ,libxext)
+ ("xrender" ,libxrender)))
(synopsis "2D graphics library")
(description "Cairo is a 2D graphics library with support for multiple output
devices. Currently supported output targets include the X Window System (via