summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-10-20 01:38:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-10-20 02:16:55 +0200
commit6c0c17527159cfb8c3c68fccec1dfa017b964947 (patch)
tree8495dce142ed7aa9a428caa6bf8f6bd7a0243a81
parent46ba5337c0c2c7d43702bc8702024e989bd93014 (diff)
downloadguix-patches-6c0c17527159cfb8c3c68fccec1dfa017b964947.tar
guix-patches-6c0c17527159cfb8c3c68fccec1dfa017b964947.tar.gz
gnu: cowsay: Swap ‘build’ and ‘install’ phases.
* gnu/packages/games.scm (cowsay)[arguments]: Invoke ‘install.sh’ during the ‘install’ phase. Delete the ‘build’ phase, as there's nothing to be built.
-rw-r--r--gnu/packages/games.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 048d597a2f..6709f02923 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -261,9 +261,9 @@ the others like yourself, that want what you have.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (delete 'install)
- (replace 'build
+ (delete 'configure) ; no configure script
+ (delete 'build) ; nothing to be built
+ (replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(zero? (system* "sh" "install.sh"
(assoc-ref outputs "out")))))