summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-10 22:55:54 +0100
committerMarius Bakke <marius@gnu.org>2022-01-11 18:36:38 +0100
commit6613661c6df478d207bfc1ce0f4785ddc25239fe (patch)
treeb25af92b81ec437834f54482503d7c0c13668aab
parente9afca64e8690306a831d8357c798f0f86fe0ea9 (diff)
downloadguix-patches-6613661c6df478d207bfc1ce0f4785ddc25239fe.tar
guix-patches-6613661c6df478d207bfc1ce0f4785ddc25239fe.tar.gz
gnu: python-cmd2: Update to 2.3.3.
* gnu/packages/python-xyz.scm (python-cmd2): Update to 2.3.3. [arguments]: Override check phase. [native-inputs]: Remove PYTHON-CODECOV, PYTHON-COVERAGE, PYTHON-DOC8, PYTHON-FLAKE8, PYTHON-SPHINX, PYTHON-SPHINX-AUTOBUILD, PYTHON-SPHINX-RTD-THEME, PYTHON-TOX, PYTHON-TWINE, and WHICH.
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5bcc96c088..e2f8c94ee7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2016-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2016, 2017, 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016, 2017, 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2021 Arun Isaac <arunisaac@systemreboot.net>
@@ -25561,34 +25561,35 @@ intended for validating data coming into Python as JSON, YAML, etc.")
(define-public python-cmd2
(package
(name "python-cmd2")
- (version "1.0.2")
+ (version "2.3.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cmd2" version))
(sha256
(base32
- "1f18plbc9yyvhn0js3d2bii9yld8zfl775gxsaw9jza5pmlg9ss2"))))
+ "0h1naik558qh48gx2iyy0a0khvw5fz0in69y84mbrhsm9nq7w3bm"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "pytest" "-vv" "-k"
+ ;; These tests fail because no EDITOR is in PATH.
+ "not test_find_editor_not_specified \
+and not test_transcript")
+ (format #t "test suite not run~%")))))))
(propagated-inputs
(list python-attrs python-colorama python-pyperclip python-wcwidth))
(native-inputs
- (list python-codecov
- python-coverage
- python-doc8
- python-flake8
- python-invoke
+ (list python-invoke
python-mock
python-pytest
python-pytest-cov
python-pytest-mock
- python-setuptools-scm
- python-sphinx
- python-sphinx-autobuild
- python-sphinx-rtd-theme
- python-tox
- python-twine
- which))
+ python-setuptools-scm))
(home-page "https://github.com/python-cmd2/cmd2")
(synopsis "Tool for building interactive command line applications")
(description