summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-12 08:51:02 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:27:20 -0400
commit2e0eb1c946543be5bdc61c17379e048cade6cb3d (patch)
tree9b09f8f05918e629f533e23fc0c8e648f178e690
parentcb4d52f1f81849b3b52ff222188aba250d68b14b (diff)
downloadguix-patches-2e0eb1c946543be5bdc61c17379e048cade6cb3d.tar
guix-patches-2e0eb1c946543be5bdc61c17379e048cade6cb3d.tar.gz
gnu: gtk-doc: Change build-system.
* gnu/packages/gtk.scm (gtk-doc) [build-system]: Change from gnu to glib-or-gtk. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f0c1fcccb2..dadd6bbf42 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1742,7 +1742,7 @@ information.")
(sha256
(base32
"05apmwibkmn1icx05l8aw241lhymcx01zvk5i499cb150bijj7li"))))
- (build-system gnu-build-system)
+ (build-system glib-or-gtk-build-system)
(arguments
`(#:parallel-tests? #f
#:phases
@@ -1750,16 +1750,16 @@ information.")
(add-after 'unpack 'patch-gtk-doc-scan
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "gtk-doc.xsl"
- (("http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl")
- (string-append (assoc-ref inputs "docbook-xsl")
- "/xml/xsl/docbook-xsl-"
- ,(package-version docbook-xsl)
- "/html/chunk.xsl"))
- (("http://docbook.sourceforge.net/release/xsl/current/common/en.xml")
- (string-append (assoc-ref inputs "docbook-xsl")
- "/xml/xsl/docbook-xsl-"
- ,(package-version docbook-xsl)
- "/common/en.xml")))
+ (("http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/html/chunk.xsl"))
+ (("http://docbook.sourceforge.net/release/xsl/current/common/en.xml")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/common/en.xml")))
#t))
(add-after 'patch-gtk-doc-scan 'patch-test-out
(lambda _
@@ -1768,7 +1768,7 @@ information.")
;; generator metafont outputs a lot of extra lines, this
;; test would always fail. Disable it for now.
(substitute* "tests/Makefile.in"
- (("empty.sh sanity.sh") "empty.sh"))
+ (("empty.sh sanity.sh") "empty.sh"))
#t))
(add-before 'configure 'fix-docbook
(lambda* (#:key inputs #:allow-other-keys)