summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-11-18 17:16:04 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-11-18 21:09:43 +0200
commit2691864533aa1d557838bc842aa88b2f9daa37d4 (patch)
tree2bdcf0af0509aa3656a7158e4a578e808799f2e5
parent675f324e12eb48323c4e2b879629f938bcf45397 (diff)
downloadguix-patches-2691864533aa1d557838bc842aa88b2f9daa37d4.tar
guix-patches-2691864533aa1d557838bc842aa88b2f9daa37d4.tar.gz
gnu: irrlicht: Fix build.
* gnu/packages/games.scm (irrlicht) [phase remove-<sys/systctl.h>]: <sys/sysctl.h> has been removed from glibc, and it is not used, so remove it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/games.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e01ad3c8d2..c80335a1ea 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3568,6 +3568,10 @@ are primarily in English, however some in other languages are provided.")
;; The actual source is buried a few directories deep.
(chdir "source/Irrlicht/")
#t))
+ (add-after 'chdir-to-source 'remove-<sys/sysctl.h>
+ (lambda _
+ (substitute* "COSOperator.cpp"
+ (("#include <sys/sysctl.h>") ""))))
(add-after 'chdir-to-source 'fix-build-env
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))