summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-12 00:12:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-03-17 10:14:00 +0100
commitc7e80a7e0d4c1ec9d6c127e6f335a5424d1e06e8 (patch)
tree987016abb704810928aa212ff7af411857ba4f2f
parent8f0069170c261642fd0b3128c3eb194e4ba2efca (diff)
downloadguix-patches-c7e80a7e0d4c1ec9d6c127e6f335a5424d1e06e8.tar
guix-patches-c7e80a7e0d4c1ec9d6c127e6f335a5424d1e06e8.tar.gz
gnu: Add r-mass.
* gnu/packages/statistics.scm (r-mass): New variable.
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 54305a2f86..189a1d2998 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -241,6 +241,27 @@ D.V. Hinkley (1997, CUP), originally written by Angelo Canty for S.")
;; Unlimited distribution
(license (license:non-copyleft "file://R/bootfuns.q"))))
+(define-public r-mass
+ (package
+ (name "r-mass")
+ (version "7.3-45")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "MASS" version))
+ (sha256
+ (base32
+ "13lp5919h2bnpmf8rbmkar8a41yx62fnx66pkvljvqf60wa29qsx"))))
+ (properties `((upstream-name . "MASS")))
+ (build-system r-build-system)
+ (home-page "http://www.stats.ox.ac.uk/pub/MASS4/")
+ (synopsis "Support functions and datasets for Venables and Ripley's MASS")
+ (description
+ "This package provides functions and datasets for the book \"Modern
+Applied Statistics with S\" (4th edition, 2002) by Venables and Ripley.")
+ ;; Either version may be picked.
+ (license (list license:gpl2 license:gpl3))))
+
(define-public r-bit
(package
(name "r-bit")