summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-07-03 11:24:19 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-07-15 13:13:40 +0200
commit313d5e62864fdcef45a0d6b334c6a210683bad88 (patch)
tree8763c84d85154fa67ec7ac66cb472bd8bc1a1d29
parent769f7d2ccf6be9399a422e36afba146a819a5d1d (diff)
downloadguix-patches-313d5e62864fdcef45a0d6b334c6a210683bad88.tar
guix-patches-313d5e62864fdcef45a0d6b334c6a210683bad88.tar.gz
gnu: Add python-pygame-sdl2.
* gnu/packages/game-development.scm (python-pygame-sdl2): New variable. Reuse package definition from previous python2-pygame-sdl2, with the following additions: [source]: Also drop “gen3” in snippet. [arguments]: Drop #:python. [native-inputs]: Use ‘python-cython’ instead of ‘python2-cython’. (python2-pygame-sdl2): Define in terms of python-pygame-sdl2.
-rw-r--r--gnu/packages/game-development.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5d5fa5cf8b..e1593c0f82 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1106,12 +1106,12 @@ to create fully featured games and multimedia programs in the python language.")
(define-public python2-pygame
(package-with-python2 python-pygame))
-(define-public python2-pygame-sdl2
+(define-public python-pygame-sdl2
(let ((real-version "2.1.0")
(renpy-version "7.4.6"))
(package
- (inherit python2-pygame)
- (name "python2-pygame-sdl2")
+ (inherit python-pygame)
+ (name "python-pygame-sdl2")
(version (string-append real-version "-for-renpy-" renpy-version))
(source
(origin
@@ -1124,12 +1124,12 @@ to create fully featured games and multimedia programs in the python language.")
'(begin
;; drop generated sources
(delete-file-recursively "gen")
+ (delete-file-recursively "gen3")
(delete-file-recursively "gen-static")
#t))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; tests require pygame to be installed first
- #:python ,python-2
#:phases
(modify-phases %standard-phases
(add-after 'set-paths 'set-sdl-vars
@@ -1149,7 +1149,7 @@ to create fully featured games and multimedia programs in the python language.")
`(("sdl-union"
,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
(native-inputs
- `(("python2-cython" ,python2-cython)))
+ `(("python-cython" ,python-cython)))
(home-page "https://www.renpy.org/")
(synopsis "Reimplementation of the Pygame API using SDL2")
(description "Pygame_SDL2 reimplements the Pygame API using SDL2,
@@ -1158,6 +1158,9 @@ While it aims to be used as a drop-in replacement, it appears to be
developed mainly for Ren'py.")
(license (list license:lgpl2.1 license:zlib)))))
+(define-public python2-pygame-sdl2
+ (package-with-python2 python-pygame-sdl2))
+
(define-public python2-renpy
(package
(name "python2-renpy")