summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2021-01-21 18:36:16 +0800
committerLudovic Courtès <ludo@gnu.org>2021-01-29 12:09:33 +0100
commitbb91875bb76a426e745592efe91002a944ec7347 (patch)
treed618ba2e4764c4516a863e6656f061c95ba997de
parentdcb594394484248a8f16d0e07ca400398d9eb5cb (diff)
downloadguix-patches-bb91875bb76a426e745592efe91002a944ec7347.tar
guix-patches-bb91875bb76a426e745592efe91002a944ec7347.tar.gz
gnu: Add python-inotify-simple.
* gnu/packages/python-xyz.scm (python-inotify-simple): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d903a678a9..2706a8c0cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -93,7 +93,7 @@
;;; Copyright © 2020 Diego N. Barbato <dnbarbato@posteo.de>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
-;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
@@ -6751,6 +6751,27 @@ need to use the older and less efficient @code{pkg_resources} package.")
finding unresolved symbols in Python code and their corresponding imports.")
(license license:bsd-3)))
+(define-public python-inotify-simple
+ (package
+ (name "python-inotify-simple")
+ (version "1.3.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chrisjbillington/inotify_simple")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dv9svrcz31acyq9smjlnw75xv3x5wpn5h6s8j8h0vrqyl3d7l05"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/chrisjbillington/inotify_simple")
+ (synopsis "Simple wrapper around inotify library")
+ (description
+ "@code{inotify-simple} is a simple wrapper around inotify library.")
+ (license license:bsd-3)))
+
(define-public python-jaraco-packaging
(package
(name "python-jaraco-packaging")