summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 22:49:09 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:13 +0200
commitb925e1f537c37f46c324b737888ce8290deb1ea8 (patch)
tree81fac63570ed58a0be8525795361af2dc6ce7a36
parentc1c35c3b0e853b2a422cd40ddef35ec741d23481 (diff)
downloadguix-patches-b925e1f537c37f46c324b737888ce8290deb1ea8.tar
guix-patches-b925e1f537c37f46c324b737888ce8290deb1ea8.tar.gz
gnu: ghc-async: Update to 2.2.1.
* gnu/packages/haskell.scm (ghc-async): Update to 2.2.1. [inputs]: Add ghc-hashable.
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 85889b20dc..3bd1757f80 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4320,7 +4320,7 @@ library for Haskell.")
(define-public ghc-async
(package
(name "ghc-async")
- (version "2.1.1.1")
+ (version "2.2.1")
(source
(origin
(method url-fetch)
@@ -4330,10 +4330,11 @@ library for Haskell.")
".tar.gz"))
(sha256
(base32
- "1qj4fp1ynwg0l453gmm27vgkzb5k5m2hzdlg5rdqi9kf8rqy90yd"))))
+ "09whscli1q5z7lzyq9rfk0bq1ydplh6pjmc6qv0x668k5818c2wg"))))
(build-system haskell-build-system)
(inputs
`(("ghc-stm" ,ghc-stm)
+ ("ghc-hashable" ,ghc-hashable)
("ghc-hunit" ,ghc-hunit)
("ghc-test-framework" ,ghc-test-framework)
("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))