summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-15 15:26:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-25 00:22:06 +0100
commitb661634bd402b64594abed3b32e38fbd3078935a (patch)
tree935ddce3855e67eac69e360f17fab6010062eca2
parent67387bbf24597af32c5aced8e03c8454419ab32b (diff)
downloadguix-patches-b661634bd402b64594abed3b32e38fbd3078935a.tar
guix-patches-b661634bd402b64594abed3b32e38fbd3078935a.tar.gz
gnu: python2-traitlets: Remove package.
* gnu/packages/python-xyz.scm (python2-traitlets): Delete variable. (python-traitlets)[properties]: Remove.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 0 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4abae2aef3..055ae67f3b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8248,7 +8248,6 @@ cluster down and deletes the throwaway profile.")
("python-six" ,python-six)))
(native-inputs
`(("python-pytest" ,python-pytest)))
- (properties `((python2-variant . ,(delay python2-traitlets))))
(home-page "https://ipython.org")
(synopsis "Configuration system for Python applications")
(description
@@ -8260,13 +8259,6 @@ is a distinct layer on top of traitlets, so you can use traitlets in your code
without using the configuration machinery.")
(license license:bsd-3)))
-(define-public python2-traitlets
- (let ((traitlets (package-with-python2 (strip-python2-variant python-traitlets))))
- (package/inherit traitlets
- (propagated-inputs
- `(("python2-enum34" ,python2-enum34)
- ,@(package-propagated-inputs traitlets))))))
-
(define-public python-jupyter-core
(package
(name "python-jupyter-core")