summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-09-11 07:25:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 07:25:43 +0200
commit9e4ef763ea8fa9feac1c2f01220d67c50bcb6ad1 (patch)
treeaff148ce979ffd1f9a760d38817f2450989ca85d
parent3ad68ec251a008d6f5875f9235e75f5ce6399f15 (diff)
downloadguix-patches-9e4ef763ea8fa9feac1c2f01220d67c50bcb6ad1.tar
guix-patches-9e4ef763ea8fa9feac1c2f01220d67c50bcb6ad1.tar.gz
gnu: Add r-flexsurv.
* gnu/packages/cran.scm (r-flexsurv): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ef6e502171..0c91ad4163 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23312,3 +23312,39 @@ to speed up repeated queries of the same set of target points.")
censored data.")
;; Any version of the GPL.
(license license:gpl3+)))
+
+(define-public r-flexsurv
+ (package
+ (name "r-flexsurv")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "flexsurv" version))
+ (sha256
+ (base32
+ "0x7p1rv51pplfyyzcg63ssb8z56mig7y0363hkr0219w3cvyq9nr"))))
+ (properties `((upstream-name . "flexsurv")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-desolve" ,r-desolve)
+ ("r-mstate" ,r-mstate)
+ ("r-muhaz" ,r-muhaz)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-quadprog" ,r-quadprog)
+ ("r-rcpp" ,r-rcpp)
+ ("r-survival" ,r-survival)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/chjackson/flexsurv-dev")
+ (synopsis "Flexible parametric survival and multi-state models")
+ (description
+ "This package provides flexible parametric models for time-to-event data,
+including the Royston-Parmar spline model, generalized gamma and generalized F
+distributions. Any user-defined parametric distribution can be fitted, given
+at least an R function defining the probability density or hazard. There are
+also tools for fitting and predicting from fully parametric multi-state
+models.")
+ (license license:gpl2+)))