summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-18 21:32:51 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-18 21:32:51 +0100
commit8e7b091c2918367a010c2bf3cfc004f267fce52e (patch)
tree2ec1fd8af346220f416944b259fdf05a963be062
parent587d10be06eb344a0d50c4edfacdb84358cf33c5 (diff)
downloadguix-patches-8e7b091c2918367a010c2bf3cfc004f267fce52e.tar
guix-patches-8e7b091c2918367a010c2bf3cfc004f267fce52e.tar.gz
gnu: emacs-lispy: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-lispy)[arguments]: Use G-expressions. Remove trailing #T.
-rw-r--r--gnu/packages/emacs-xyz.scm49
1 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ce01f65bfd..c5401624d9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9630,31 +9630,30 @@ navigate code in a tree-like fashion.")
(native-inputs
(list which emacs-clojure-mode emacs-undercover))
(arguments
- `(#:include (cons* "^lispy-clojure\\.clj$"
- "^lispy-python\\.py$"
- %default-include)
- #:phases
- ;; XXX: Some failing tests
- (modify-phases %standard-phases
- (add-before 'check 'make-test-writable
- (lambda _
- (make-file-writable "lispy-test.el")
- #t))
- (add-before 'check 'remove-failing-test
- (lambda _
- (emacs-batch-edit-file "lispy-test.el"
- `(progn
- (dolist (test '("lispy-eval-python-str" "lispy--clojure-dot-object"))
- (goto-char (point-min))
- (re-search-forward
- (concat "ert-deftest " test))
- (beginning-of-line)
- (kill-sexp))
- (basic-save-buffer)))
- #t)))
- #:tests? #t
- ;; Set BEMACS to prevent the test suite from loading straight.el.
- #:test-command '("make" "test" "BEMACS=emacs -batch")))
+ (list
+ #:include #~(cons* "^lispy-clojure\\.clj$"
+ "^lispy-python\\.py$"
+ %default-include)
+ #:phases
+ ;; XXX: Some failing tests
+ #~(modify-phases %standard-phases
+ (add-before 'check 'make-test-writable
+ (lambda _
+ (make-file-writable "lispy-test.el")))
+ (add-before 'check 'remove-failing-test
+ (lambda _
+ (emacs-batch-edit-file "lispy-test.el"
+ `(progn
+ (dolist (test '("lispy-eval-python-str" "lispy--clojure-dot-object"))
+ (goto-char (point-min))
+ (re-search-forward
+ (concat "ert-deftest " test))
+ (beginning-of-line)
+ (kill-sexp))
+ (basic-save-buffer))))))
+ #:tests? #t
+ ;; Set BEMACS to prevent the test suite from loading straight.el.
+ #:test-command #~(list "make" "test" "BEMACS=emacs -batch")))
(synopsis "Modal S-expression editing")
(description
"Due to the structure of Lisp syntax it's very rare for the programmer