summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-18 21:31:00 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-18 21:31:00 +0100
commit256cdde7adfd978fe78ca08189c3843fd1e40fe9 (patch)
tree00bec3efe97960b92881adfe97fe770afc3fc905
parent5f8e89b702e72a7a1135a5fae193f27d0f36b292 (diff)
downloadguix-patches-256cdde7adfd978fe78ca08189c3843fd1e40fe9.tar
guix-patches-256cdde7adfd978fe78ca08189c3843fd1e40fe9.tar.gz
gnu: emacs-org-pomodoro: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-org-pomodoro)[arguments]: Use G-expressions. Remove trailing #T.
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 40d8ec6fef..59b1f33205 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8008,28 +8008,28 @@ save, it exports back to the original non-Org file.")
(propagated-inputs
(list emacs-alert))
(arguments
- `(#:include (cons "^resources\\/" %default-include)
- #:tests? #t
- #:test-command '("emacs" "--batch"
- "-l" "org-pomodoro-tests.el"
- "-f" "ert-run-tests-batch-and-exit")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'make-tests-writable
- (lambda _
- (make-file-writable "org-pomodoro-tests.el")
- #t))
- (add-before 'check 'add-require
- (lambda _
- (emacs-batch-edit-file "org-pomodoro-tests.el"
- `(progn (progn (goto-char (point-min))
- (re-search-forward
- "ert-deftest")
- (beginning-of-line)
- (forward-line -1)
- (insert "(require 'org-pomodoro)"))
- (basic-save-buffer)))
- #t)))))
+ (list
+ #:include #~(cons "^resources\\/" %default-include)
+ #:tests? #t
+ #:test-command
+ (list
+ "emacs" "--batch"
+ "-l" "org-pomodoro-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'make-tests-writable
+ (lambda _
+ (make-file-writable "org-pomodoro-tests.el")))
+ (add-before 'check 'add-require
+ (lambda _
+ (emacs-batch-edit-file "org-pomodoro-tests.el"
+ `(progn (progn (goto-char (point-min))
+ (re-search-forward "ert-deftest")
+ (beginning-of-line)
+ (forward-line -1)
+ (insert "(require 'org-pomodoro)"))
+ (basic-save-buffer))))))))
(home-page "https://github.com/marcinkoziej/org-pomodoro")
(synopsis "Pomodoro technique for org-mode")
(description "@code{emacs-org-pomodoro} adds very basic support for