summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-28 17:29:39 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 11:01:18 +0200
commit04ee040dd4958c8f6c0aee7121cb6195d4605028 (patch)
treea0436cc23c489e064f68c6f723d61eb732a84e76
parent5412b14ba6020df267e096727af9b01393b2ee33 (diff)
downloadguix-patches-04ee040dd4958c8f6c0aee7121cb6195d4605028.tar
guix-patches-04ee040dd4958c8f6c0aee7121cb6195d4605028.tar.gz
gnu: Add r-km-ci.
* gnu/packages/cran.scm (r-km-ci): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5cf5b0e639..8e41f93e7d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23396,3 +23396,27 @@ It includes methods to simulate and analyze outbreaks. The methodology is
described in @url{https://doi.org/10.1093/molbev/msu121,Didelot et al. (2014)}
and @url{https://doi.org/10.1093/molbev/msw275,Didelot et al. (2017)}.")
(license license:gpl2+)))
+
+(define-public r-km-ci
+ (package
+ (name "r-km-ci")
+ (version "0.5-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "km.ci" version))
+ (sha256
+ (base32
+ "1l6kw8jppaa1802yc5pbfwwgac56nhwc9p076ivylhms4w7cdf8v"))))
+ (properties `((upstream-name . "km.ci")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-survival" ,r-survival)))
+ (home-page "https://cran.r-project.org/web/packages/km.ci/")
+ (synopsis "Confidence intervals for the Kaplan-Meier estimator")
+ (description
+ "This package computes various @dfn{confidence intervals} (CI) for the
+Kaplan-Meier estimator, namely: Petos CI, Rothman CI, CIs based on Greenwoods
+variance, Thomas and Grunkemeier CI and the simultaneous confidence bands by
+Nair and Hall and Wellner.")
+ (license license:gpl2+)))