summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2021-12-21 22:20:01 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-23 18:13:00 +0100
commit00cf011a831fe3b3e6f623af1994ed2ec98855d0 (patch)
treec35a7d298dbb9c63e93a61f15422a85a60271d96
parent4ea4db5f8a3c863ceb19da90ff55d66b8a5648c7 (diff)
downloadguix-patches-00cf011a831fe3b3e6f623af1994ed2ec98855d0.tar
guix-patches-00cf011a831fe3b3e6f623af1994ed2ec98855d0.tar.gz
gnu: Add libuev.
* gnu/packages/linux.scm (libuev): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6f41a7fcf0..bab88c7d88 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4903,6 +4903,28 @@ useful *BSD sys/queue.h and sys/tree.h API's")
(home-page "https://troglobit.com/projects/libite/")
(license license:expat)))
+(define-public libuev
+ (package
+ (name "libuev")
+ (version "2.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/troglobit/libuev")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ih82lxfdcq179kknzdl5c8vi1l0n5j7yh68y8f6kwsrm457paf7"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Lightweight event loop library for epoll family APIs")
+ (description "This package provides small event loop that wraps the
+epoll family of APIs.")
+ (home-page "https://troglobit.com/projects/libuev/")
+ (license license:expat)))
+
(define-public libraw1394
(package
(name "libraw1394")