summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2020-09-16 12:20:08 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-21 23:30:53 +0200
commitd076ddc560b61c77b63ae84059782cf2330893cc (patch)
tree0749099070349d9f13fd7d96411a0a0a809bc289
parentde8cc74749525aa4266137c25a38d46361dacb9b (diff)
downloadguix-patches-d076ddc560b61c77b63ae84059782cf2330893cc.tar
guix-patches-d076ddc560b61c77b63ae84059782cf2330893cc.tar.gz
gnu: Add python-citeproc-py.
* gnu/packages/python-xyz.scm (python-citeproc-py): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 004f07cec2..e14f4c79ee 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22046,3 +22046,28 @@ and pandoc-citeproc.")
a Python library to convert RELAX NG schemata in Compact syntax (rnc) to
equivalent schemata in the XML-based default RELAX NG syntax.")
(license license:expat)))
+
+(define-public python-citeproc-py
+ (package
+ (name "python-citeproc-py")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "citeproc-py" version))
+ (sha256
+ (base32
+ "00aaff50jy4j0nakdzq9258z1gzrac9baarli2ymgspj88jg5968"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-lxml" ,python-lxml)
+ ("python-rnc2rng" ,python-rnc2rng)))
+ (home-page
+ "https://github.com/brechtm/citeproc-py")
+ (synopsis "Citations and bibliography formatter")
+ (description
+ "Citeproc-py is a CSL processor for Python. It aims to implement the
+CSL 1.0.1 specification. citeproc-py can output styled citations and
+bibliographies in a number of different output formats. Currently supported
+are plain text, reStructuredText and HTML.")
+ (license license:bsd-2)))