summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-02-09 21:11:09 +0000
committerLudovic Courtès <ludo@gnu.org>2022-02-16 16:49:27 +0100
commit6481dbda5100e9b0ff9c5221280d2c0cadd663b7 (patch)
tree8c6855a08c45790be24a4c2b0d899bb3ed83638a
parent35ea49daf6cdef5bf6156dd90add77cede364a4b (diff)
downloadguix-patches-6481dbda5100e9b0ff9c5221280d2c0cadd663b7.tar
guix-patches-6481dbda5100e9b0ff9c5221280d2c0cadd663b7.tar.gz
gnu: c-vise: Fix linkage.
* gnu/packages/debug.scm (c-vise)[arguments][#:phases]: Fix linkage to clang and llvm shared libraries. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/debug.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 94312e7c05..24d17d95b0 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -199,6 +199,11 @@ tools that process C/C++ code.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-linkage
+ (lambda _
+ (substitute* "clang_delta/CMakeLists.txt"
+ (("\\$\\{LLVM_LINK_LLVM_DYLIB\\}") "True")
+ ((" LLVM") " LLVMSupport"))))
(add-before 'build 'hardcode-paths
(lambda _
(substitute* "cvise.py"