summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-02-10 19:02:03 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-02-16 12:45:29 +0200
commit5acb9b70bdb0f297d101d48936cbcc8b6533673f (patch)
tree9da8976199791b782674aeeddb7135cf41b1c18c
parent6516a2e3fe1df4915ac0249b844cbdff731e9a21 (diff)
downloadguix-patches-5acb9b70bdb0f297d101d48936cbcc8b6533673f.tar
guix-patches-5acb9b70bdb0f297d101d48936cbcc8b6533673f.tar.gz
gnu: Add julia-gpuarrays.
* gnu/packages/julia-xyz.scm (julia-gpuarrays): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/julia-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 16e25a6c84..9a2c20e94c 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2216,6 +2216,32 @@ finite elements analysis, Geo applications, and general geometry manipulations
- while offering a Julian API, that still allows performant C-interop.")
(license license:expat)))
+(define-public julia-gpuarrays
+ (package
+ (name "julia-gpuarrays")
+ (version "8.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaGPU/GPUArrays.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "129q8m94b2xq3vij28pkb7dry3r7qbiqrz72a26ma9kilcr35gk4"))))
+ (build-system julia-build-system)
+ (inputs
+ (list julia-adapt))
+ (home-page "https://github.com/JuliaGPU/GPUArrays.jl")
+ (synopsis "Reusable GPU array functionality for various GPU backends")
+ (description "This package is the counterpart of AbstractArray interface,
+but for GPU array types. It provides functionality and tooling to speed-up
+development of new GPU array types. This package is not intended for end
+users; instead, you should use one of the packages that builds on
+@code{GPUArrays.jl}, such as @code{CUDA.jl}, @code{oneAPI.jl} or
+@code{AMDGPU.jl}.")
+ (license license:expat)))
+
(define-public julia-gr
(package
(name "julia-gr")