summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-02-10 19:02:01 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-02-16 12:45:24 +0200
commit439d48d29da1b4691ac19880527117f9e8016b18 (patch)
treeb992edc32e82e270c889c2ab558872738fdd59d7
parentea0c7d655cf2c5394817faeadfe6b795901e9f12 (diff)
downloadguix-patches-439d48d29da1b4691ac19880527117f9e8016b18.tar
guix-patches-439d48d29da1b4691ac19880527117f9e8016b18.tar.gz
gnu: Add julia-bfloat16s.
* gnu/packages/julia-xyz.scm (julia-bfloat16s): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/julia-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 47102ef6c5..b788276613 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -362,6 +362,34 @@ code easy by supplying a framework for writing and running groups of
benchmarks as well as comparing benchmark results.")
(license license:expat)))
+(define-public julia-bfloat16s
+ ;; Not tagged upstream
+ (let ((commit "ef6051e4308ed0c02f10168b99d226237e0ae33c")
+ (version "0.2.0"))
+ (package
+ (name "julia-bfloat16s")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaMath/BFloat16s.jl")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16sr578k4i47lhziri47nvspdrsni2wc1qjhs6hzffh9si6a7jfq"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaMath/BFloat16s.jl")
+ (synopsis "Define BFloat16 data type")
+ (description "This package defines the @code{BFloat16} data type. The
+only currently available hardware implementation of this datatype are Google's
+Cloud TPUs. As such, this package is suitable to evaluate whether using TPUs
+would cause precision problems for any particular algorithm, even without
+access to TPU hardware. Note that this package is designed for functionality,
+not performance, so this package should be used for precision experiments
+only, not performance experiments.")
+ (license license:expat))))
+
(define-public julia-bioalignments
(package
(name "julia-bioalignments")