summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-02-10 19:02:00 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-02-16 12:45:21 +0200
commitea0c7d655cf2c5394817faeadfe6b795901e9f12 (patch)
treedb063f3cb4e37354a49ef7e5770acb604192ee12
parent0f87f2e69d5edf5e9b596867b1189cc994c642d5 (diff)
downloadguix-patches-ea0c7d655cf2c5394817faeadfe6b795901e9f12.tar
guix-patches-ea0c7d655cf2c5394817faeadfe6b795901e9f12.tar.gz
gnu: Add julia-juno.
* gnu/packages/julia-xyz.scm (julia-juno): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/julia-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 2fcc4cf83e..47102ef6c5 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3045,6 +3045,34 @@ and printing JSON documents.")
focus on speed and slick struct mapping.")
(license license:expat)))
+(define-public julia-juno
+ (package
+ (name "julia-juno")
+ (version "0.8.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JunoLab/Juno.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02ryj5blnrmck3jisrpwn1x563i7rsg65d7zms52njsvv499gygk"))))
+ (build-system julia-build-system)
+ (inputs
+ (list julia-media))
+ (home-page "https://github.com/JunoLab/Juno.jl")
+ (synopsis "Integrated Development Environment (IDE) for Julia")
+ (description "This package provides tools to help you develop code. Juno
+is built on the Atom text editor. Juno consists of both Julia and Atom
+packages in order to add Julia-specific enhancements, such as syntax
+highlighting, a plot pane, integration with Julia's debugger, a console for
+running code, and much more.
+
+Consider that the package is “maintenance-only mode” and only receives bug
+fixes. The Julia IDE effort is pointed to extension for VSCode.")
+ (license license:expat)))
+
(define-public julia-latexstrings
(package
(name "julia-latexstrings")