summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-16 09:57:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-02-16 09:57:40 +0200
commite358706058cd297044deac4c5f4879389bd7a524 (patch)
tree3403fa5f8b279ec95fbd77f800ad94e10d8e3827
parent52269e27c628d34af896e95347870b1755cb3e5f (diff)
downloadguix-patches-e358706058cd297044deac4c5f4879389bd7a524.tar
guix-patches-e358706058cd297044deac4c5f4879389bd7a524.tar.gz
gnu: vim: Adjust autodetected plugin directories.
* gnu/packages/aux-files/guix.vim: Autodetect plugins installed with guix-home. Add */after directories at the end of the runtimepath.
-rw-r--r--gnu/packages/aux-files/guix.vim8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/aux-files/guix.vim b/gnu/packages/aux-files/guix.vim
index 7dc359e52b..9397c53701 100644
--- a/gnu/packages/aux-files/guix.vim
+++ b/gnu/packages/aux-files/guix.vim
@@ -1,7 +1,13 @@
" This appends all of the vim plugins to the end of Vim's runtimepath.
-for directory in ["/run/current-system/profile", $HOME . "/.guix-profile", $GUIX_PROFILE, $GUIX_ENVIRONMENT]
+for directory in ["/run/current-system/profile", $HOME . "/.guix-profile", $HOME ."/.guix-home/profile", $GUIX_PROFILE, $GUIX_ENVIRONMENT]
let vimplugins = directory . "/share/vim/vimfiles"
if isdirectory(vimplugins)
let &rtp = join([&rtp,vimplugins], ',')
endif
endfor
+" Unconditionally add */after directories last, as intended by upstream
+" TODO: Remove duplicate */after directories
+for directory in [$VIM . "/vimfiles", $HOME ."/.vim"]
+ let vimplugins = directory . "/after"
+ let &rtp = join([&rtp,vimplugins], ',')
+endfor