summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-15 21:54:13 +0100
committerMarius Bakke <marius@gnu.org>2022-02-15 22:42:26 +0100
commitd87c2db4f7923a9aeb4983c53b557f0b1c74c28f (patch)
treeec67021ac4079befef30fa31292d48e2a64870c0
parentda696ee165991f85e7c29665f38a481c52915ebd (diff)
downloadguix-patches-d87c2db4f7923a9aeb4983c53b557f0b1c74c28f.tar
guix-patches-d87c2db4f7923a9aeb4983c53b557f0b1c74c28f.tar.gz
gnu: python-moto: Disable flaky test.
* gnu/packages/python-xyz.scm (python-moto)[arguments]: Skip one test. Don't use ADD-INSTALLED-PYTHONPATH while at it. [inputs]: Remove label, too.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 537403240d..9a7b2d3890 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13994,13 +13994,15 @@ text.")
(substitute* (find-files "tests" "\\.py$")
(("#!/bin/bash") (string-append "#!" bash-exec))))))
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv" "-m" "not network" "-k"
(string-append
+ ;; XXX: This test is timing sensitive and may
+ ;; fail non-deterministically.
+ "not test_cancel_pending_job"
;; These tests require Docker.
- "not test_terminate_job"
+ " and not test_terminate_job"
" and not test_invoke_function_from_sqs_exception"
" and not test_rotate_secret_lambda_invocations"
;; These tests also require the network.
@@ -14017,7 +14019,7 @@ text.")
python-pytest
python-sure))
(inputs
- `(("bash" ,bash-minimal)))
+ (list bash-minimal))
(propagated-inputs
(list python-aws-xray-sdk
python-boto