summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-16 15:11:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-02-16 15:48:10 +0200
commit73e466002091168e532706d82128fd3e539ac519 (patch)
tree572cfdb0672aa01c9ae7e2cd5725257e7cb58f67
parent194b1a9297206b570328b48fd98b8f8890ad024d (diff)
downloadguix-patches-73e466002091168e532706d82128fd3e539ac519.tar
guix-patches-73e466002091168e532706d82128fd3e539ac519.tar.gz
gnu: lz4: Only build with valgrind on supported systems.
* gnu/packages/compression.scm (lz4)[native-inputs]: Only add valgrind when valgrind is supported on that system.
-rw-r--r--gnu/packages/compression.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 2b5cbf8850..4e0d4e9196 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -813,8 +813,11 @@ decompression of some loosely related file formats used by Microsoft.")
(build-system gnu-build-system)
(outputs (list "out" "static"))
(native-inputs
- (list ;; For tests.
- python valgrind))
+ (append
+ (list python) ;; For tests.
+ (if (member (%current-system) (package-supported-systems valgrind))
+ (list valgrind)
+ '())))
(arguments
`(;; Not designed for parallel testing.
;; See https://github.com/lz4/lz4/issues/957#issuecomment-737419821