summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-29 19:20:08 -0500
committerLeo Famulari <leo@famulari.name>2022-02-16 14:34:31 -0500
commit34e1454d8600d26de0b77d3307338cd34008e393 (patch)
tree83b9733980ad8f69556d3ff59ab470c928675f7f
parent0dc0d87839ccb7e85f99d7469da1ef478a1c8dc4 (diff)
downloadguix-patches-34e1454d8600d26de0b77d3307338cd34008e393.tar
guix-patches-34e1454d8600d26de0b77d3307338cd34008e393.tar.gz
gnu: Remove QuiteRSS due to dependency on QtWebKit.
According to the upstream developers, "Unfortunately, qtwebkit won't work without it. Everything is very much tied to qtwebkit." https://github.com/QuiteRSS/quiterss/issues/1470 Additionally, there is no work being done to remove this dependency: https://github.com/QuiteRSS/quiterss/issues/909 Other distros are removing this package as part of the effort to remove QtWebKit: https://bugzilla.redhat.com/show_bug.cgi?id=1872819 https://bugs.gentoo.org/687840 See <https://issues.guix.gnu.org/53289> for more information about this change. * gnu/packages/syndication.scm (quiterss): Remove variable.
-rw-r--r--gnu/packages/syndication.scm50
1 files changed, 0 insertions, 50 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 421751bed2..cd35b665dc 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -511,56 +511,6 @@ a simple interface that makes it easy to organize and browse feeds.")
formats, including all versions of RSS and Atom.")
(license license:gpl2+)))
-(define-public quiterss
- (package
- (name "quiterss")
- (version "0.19.4")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/QuiteRSS/quiterss")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1cgvl67vhn5y7bj5gbjbgk26bhb0196bgrgsp3r5fmrislarj8s6"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* (find-files "." "\\.cpp$")
- ;; Disable Google Analytics spyware by default,
- ;; removing completely is not trivial.
- (("settings\\.value\\(\"Settings/statisticsEnabled2\", true\\)")
- "settings.value(\"Settings/statisticsEnabled2\", false)")
- ;; Disable update check spyware by default, otherwise runs
- ;; at every startup, nasty. Not needed on GNU Guix as a
- ;; feature either way.
- (("settings\\.value\\(\"Settings/updateCheckEnabled\", true\\)")
- "settings.value(\"Settings/updateCheckEnabled\", false)"))
- #t))))
- (build-system qt-build-system)
- (arguments
- `(#:tests? #f ;; no test suite
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "qmake" "CONFIG+=release"
- (string-append "PREFIX="
- (assoc-ref outputs "out"))
- (string-append "QMAKE_LRELEASE="
- (assoc-ref inputs "qttools")
- "/bin/lrelease")))))))
- (native-inputs
- (list pkg-config qttools))
- (inputs
- (list qtwebkit qtbase-5 qtmultimedia phonon sqlite))
- (home-page "https://quiterss.org/")
- (synopsis "RSS/Atom news feeds reader written on Qt/C++")
- (description "QuiteRSS is an RSS/Atom news feeds reader written on Qt/C++
-that aims to be quite fast and comfortable to its user.")
- (license license:gpl3+)))
-
(define-public gfeeds
(package
(name "gfeeds")