summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-15 22:13:53 +0100
committerMarius Bakke <marius@gnu.org>2022-02-15 22:42:26 +0100
commit06111d939687e45527b73f7c54b17dcb48a6c38f (patch)
treecf183c8aafdba05196348783f7bf9ca81ccd3556
parentd87c2db4f7923a9aeb4983c53b557f0b1c74c28f (diff)
downloadguix-patches-06111d939687e45527b73f7c54b17dcb48a6c38f.tar
guix-patches-06111d939687e45527b73f7c54b17dcb48a6c38f.tar.gz
gnu: fish: Disable flaky test.
* gnu/packages/shells.scm (fish)[arguments]: Delete test that occasionally fails.
-rw-r--r--gnu/packages/shells.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 3cd316753e..9f07afc3fb 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
@@ -148,6 +148,12 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
(lambda* (#:key inputs #:allow-other-keys)
(let ((coreutils (assoc-ref inputs "coreutils"))
(bash (assoc-ref inputs "bash")))
+ ;; This test sporadically fails in the build container
+ ;; because of leftover zombie processes, which are not
+ ;; reaped automatically:
+;; "Found existing zombie processes. Clean up zombies before running this test."
+ ;; Disabling parallel tests does not reliably prevent it.
+ (delete-file "tests/checks/jobs.fish")
;; This test fails.
(delete-file "tests/checks/pipeline-pgroup.fish")
;; This one tries to open a terminal & can't simply be deleted.