summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-12 23:25:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-13 09:37:52 +0100
commitf0ada3f78f5e2eabd9570b3524eea601eca00ab2 (patch)
tree852d2c676680c137dde02155aa67722b7d9175aa
parent6ce3c0043bc16358472e8b6d80eb202fa7098ce1 (diff)
downloadguix-patches-f0ada3f78f5e2eabd9570b3524eea601eca00ab2.tar
guix-patches-f0ada3f78f5e2eabd9570b3524eea601eca00ab2.tar.gz
gnu: Add texlive-stmaryrd/fixed.
* gnu/packages/tex.scm (texlive-stmaryrd/fixed): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3d54a1e863..753a6e8d8d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6534,6 +6534,25 @@ use under LaTeX; the package supports the @code{only} option (provided by the
the whole font.")
(license license:lppl))))
+(define-public texlive-stmaryrd/fixed
+ (package
+ (inherit texlive-stmaryrd)
+ (name "texlive-stmaryrd-fixed")
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-stmaryrd)
+ ((#:tex-directory _ #t)
+ "latex/stmaryrd")
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'copy-files 'unchdir
+ (lambda _
+ (chdir "../../..")))
+ (add-after 'copy-files 'delete-extra-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/source/fonts/stmaryrd/build"))))))))))
+
(define-deprecated-package texlive-fonts-stmaryrd texlive-stmaryrd)
(define-public texlive-latex-subfigure